Release Notes for RADIUS Server

Description:

Remote Authentication Dial-In User Service (RADIUS) is a networking protocol that provides centralized authentication, authorization, and accounting for wireless network access.

Version: 2.2.9-0219

(2016/08/22)

  1. Added support for TLS 1.2.
  2. Updated TLS cipher list to enhance security.
  3. Fixed an issue where a wrong password might be displayed in the log after login failed.
  4. Fixed an issue where new logs could not be generated after clearing old ones from the UI.
  5. Fixed an issue where log files might be lost after upgrading the package.
  6. Improved overall stability.

Version: 2.2.5-0104

(2016/06/07)

  1. Upgraded to be compatible with SRM 1.1.

Version: 2.2.5-0214

(2016/06/06)

  1. Fixed an issue where RADIUS cannot authenticate against LDAP server.

Version: 2.2.5-0102

(2016/04/28)

  1. Blocked LDAP accounts will not be authenticated.

Version: 2.2.5-0212

(2016/03/24)

  1. Upgraded to be compatible with DSM 6.0.

Version: 2.2.5-0101

(2015/10/07)

  1. Added the support for RT1900ac and DS216play.

Version: 2.2.5-0095

(2015/07/01)

  1. Fixed an issue where RADIUS Server could fail to enable after being disabled.

Version: 1.1-0094

(2015/05/21)

  1. Fixed an issue where the port number had to be over 1024.

Version: 1.1-0092

(2015/05/12)

  1. Minor bug fixes.

Version: 1.1-0079

(2014/12/25)

  1. Fixed a service stability issue caused by authentication packets containing invalid data.
  2. Minor bug fixes.

Version: 1.1-0077

(2014/11/26)

  1. Minor bugs fixed

Version: 1.1-0076

(2014/11/07)

  1. Upgraded to version 2.2.5.
  2. Fixed an issue that could occasionally cause authentication fail.

Version: 1.1-0072

(2014/09/24)

  1. Certified by Synology Trust Level.
  2. Minor bugs fixed.

Version: 1.1-0061

(2014/09/22)

Add DS415+ support

Version: 1.1-0060

(2014/04/29)

  1. Fixed a security issue allowing denial of service attacks when TLS-based EAP authentication was used. (CVE-2012-3547)

Version: 1.0-0029

(2014/04/17)

  1. Fixed a security issue allowing denial of service attacks when TLS-based EAP authentication was used. (CVE-2012-3547)

Version: 1.1-0059

(2014/03/10)

  1. Updated to be compatible with DSM 5.0.

Version: 1.0-0028

(2014/03/04)

  1. Fixed a security issue to prevent unauthorized access.

Version: 1.0-0027

(2013/10/08)

  1. Fixed an issue where AD domain users might not be able to log into DSM successfully if DSM version is 4.2 or previous versions.

Version: 1.0-0026

(2013/08/27)

  1. Minor Bug Fixes.

Version: 1.0-0016

(2013/04/18)

  1. Fixed an issue where users could not obtain authentication successfully by specifying domain\username during login.

Version: 1.0-0013

(2013/03/04)

The initial release.