My users do not have permission to use Synology MailPlus. What can I do?
Last updated:Aug 2, 2023
My users do not have permission to use Synology MailPlus. What can I do?
Symptoms
When your users sign in to Synology MailPlus, they see either of the following messages:
- Sorry, this user account has not been assigned proper privileges to perform this action.
- The MailPlus folder is missing, or you do not have permission to access the folder. Please contact your system administrator.
Diagnosis
Both messages indicate that your users do not meet the usage requirements, such as:
- They do not have application permission to MailPlus Server and MailPlus.
- They do not have access permission to the MailPlus shared folder.
- Their accounts are not activated on MailPlus Server.
- Their accounts are not listed on a domain user list.
Resolution
Checking application permission
- Go to Control Panel > User (or User & Group > User).
- Select the target user and click Edit.
- Go to the Applications tab. If the user's permission to any of Synology Contacts, Synology MailPlus, and Synology MailPlus Server is Deny, the user will be blocked from accessing MailPlus. Please make sure Allow is shown in the Preview column for these three packages.
Checking shared folder permission
At Control Panel
- Go to Control Panel > Shared Folder.
- Select the MailPlus shared folder and click Edit.
- Go to the Permissions tab. Check the following:
- Select the user type from the drop-down menu and make sure the checkbox under No access is unticked.
- Select the group type from the drop-down menu and make sure there is - under Group permissions and the checkbox under No access is unticked.
Note that it is normal for No access to be shown in the Preview column and this wouldn't affect users' access to MailPlus. A user list should look like below:
At File Station
- Launch File Station.
- Right-click on the MailPlus folder and select Properties.
- Go to the Permission tab. Check the following settings but note that you should refrain from modifying on your own:
- Owner should have Full Control.
- Double-click Everyone to launch the Permission Editor. Check if Traverse folders/Execute files is ticked. If not, please do not tick it on your own.
- Owner should have Full Control.
- If any of the above settings differ, go to Package Center > Synology MailPlus Server to stop the package and run it a few seconds later. Doing this allows the settings to be reset to default.
Activating accounts on MailPlus Server
- Launch Synology MailPlus Server.
- Go to the Account page to check if the user account has been activated. If not, activate the user to grant them access to MailPlus.1
Checking domain user lists
- Launch Synology MailPlus Server.
- Go to the Domain page and double-click each domain to check if the user belongs to any of them. Users outside the MailPlus domains cannot use MailPlus.