Release Notes for MediaWiki

MediaWiki is an extremely powerful, scalable and feature-rich open source wiki package that uses PHP to process and display data stored in a database, such as MySQL. It is now widely used by projects such as Wikipedia and many other wikis. Users can make good use of its features and extensions to edit wiki pages.

Version: 1.35.5-1050


(2022-04-26)

Compatibility and Installation

  1. Apache 2.4 is required.
  2. Updated to be compatible with DSM 7.0.

Version: 1.35.5-1056


(2022-02-17)

Important Note

  1. Starting from this version, MediaWiki no longer supports retaining or restoring package-related data after an uninstallation.

Compatibility and Installation

  1. PHP 7.4 is required.
  2. Apache 2.4 is required.

What's New

  1. Updated to version 1.35.5.

Fixed Issues

  1. Fixed multiple security vulnerabilities (CVE-2021-41798, CVE-2021-41799, CVE-2021-41800, CVE-2021-45038, CVE-2021-44857, CVE-2021-44858, CVE-2021-46150, CVE-2021-46149, CVE-2021-46148, CVE-2021-46147, CVE-2021-46146, CVE-2021-45474, CVE-2021-45473, CVE-2021-45472, CVE-2021-45471).
  2. Fixed an issue where users might fail to install the package.
  3. Fixed an issue where users might encounter the 500 error after updating the package.
  4. Minor bug fixes.

Version: 1.35.3-1040


(2021-08-31)

What's New

  1. Updated to version 1.35.3.

Fixed Issues

  1. Fixed multiple security vulnerabilities (CVE-2021-35197, CVE-2021-30159, CVE-2021-30155, CVE-2021-30152, CVE-2021-30458, CVE-2021-30156, CVE-2021-30158, CVE-2021-30157, CVE-2021-30154).
  2. Minor bug fixes.

Version: 1.35.1-1033


(2021-06-01)

Compatibility and Installation

  1. Updated to be compatible with DSM 7.0.
  2. If PHP 7.3 was not installed, the system will automatically install it after the update to ensure package functionality.

What's New

  1. Updated to MediaWiki 1.35.1.

Version: 1.35.5-0154


(2022-05-10)

Important Note

  1. Starting from this version, MediaWiki no longer supports retaining or restoring package-related data after an uninstallation.

Compatibility and Installation

  1. PHP 7.4 is required.
  2. Apache 2.4 is required.

What's New

  1. Updated to version 1.35.5.

Fixed Issues

  1. Fixed multiple security vulnerabilities (CVE-2021-41798, CVE-2021-41799, CVE-2021-41800, CVE-2021-45038, CVE-2021-44857, CVE-2021-44858, CVE-2021-46150, CVE-2021-46149, CVE-2021-46148, CVE-2021-46147, CVE-2021-46146, CVE-2021-45474, CVE-2021-45473, CVE-2021-45472, CVE-2021-45471).
  2. Fixed an issue where users might fail to install the package.
  3. Fixed an issue where users might encounter the 500 error after updating the package.
  4. Minor bug fixes.

Version: 1.35.3-0144


(2021-09-07)

What's New

  1. Updated to version 1.35.3.

Fixed Issues

  1. Fixed multiple security vulnerabilities (CVE-2021-35197, CVE-2021-30159, CVE-2021-30155, CVE-2021-30152, CVE-2021-30458, CVE-2021-30156, CVE-2021-30154, CVE-2021-30157, CVE-2021-30158).
  2. Minor bug fixes.

Version: 1.35.1-0140


(2021-02-23)

Important Note

  1. This update is expected to be available in all regions within the next few days. The actual time of release may vary slightly depending on regions.

What's New

  1. Updated to version 1.35.1.
  2. PHP 7.3 is required.

Fixed Issues

  1. Fixed multiple security vulnerabilities (CVE-2020-35480, CVE-2020-35479, CVE-2020-35477, CVE-2020-35478, CVE-2020-35474, CVE-2020-35475, CVE-2020-25813, CVE-2020-25814, CVE-2020-25815, CVE-2020-25828, CVE-2020-25869, CVE-2020-15005, CVE-2020-10959, CVE-2020-10960, CVE-2019-19709).
  2. Minor bug fixes.

Version: 1.33.1-0136


(2020-04-28)

What's New

  1. Updated to version 1.33.1.
  2. PHP 7.2 is required.

Version: 1.30.0-0131


(2018-03-20)
  1. Upgraded to version 1.30.0 to fix multiple security vulnerabilities regarding MediaWiki (CVE-2017-8814, CVE-2017-8812, CVE-2017-8815, CVE-2017-8810, CVE-2017-8809, CVE-2017-8808, CVE-2017-8811).

Version: 1.28.2-0126


(2017-12-13)
  1. Enhanced overall stability.

Version: 1.28.2-0125


(2017-06-29)
  1. Upgraded to be compatible with MariaDB 10.

Version: 1.28.2-0122


(2017-05-03)

Upgraded to version 1.28.2 to address multiple vulnerabilities (CVE-2017-0361, CVE-2017-0362, CVE-2017-0363, CVE-2017-0364, CVE-2017-0365, CVE-2017-0366, CVE-2017-0367, CVE-2017-0368, CVE-2017-0369, CVE-2017-0370 and CVE-2017-0372).

Version: 1.27.1-0119


(2017-04-25)
  1. Upgrade the compatibility level of MediaWiki 1.27 or later

Version: 1.27.1-0118


(2017-02-21)
  1. Fixed an issue where incompatible databases might be installed during installation.

Version: 1.27.1-0117


(2017-01-04)
  1. Upgraded to 1.27.1.

Version: 1.26.2-0110


(2016-06-22)
  1. Upgraded to version 1.26.2.

Version: 1.23.13-0108


(2016-03-03)
  1. Upgraded version to 1.23.13.

Version: 1.35.5-0154


(2022-05-10)

Important Note

  1. Starting from this version, MediaWiki no longer supports retaining or restoring package-related data after an uninstallation.

Compatibility and Installation

  1. PHP 7.4 is required.
  2. Apache 2.4 is required.

What's New

  1. Updated to version 1.35.5.

Fixed Issues

  1. Fixed multiple security vulnerabilities (CVE-2021-41798, CVE-2021-41799, CVE-2021-41800, CVE-2021-45038, CVE-2021-44857, CVE-2021-44858, CVE-2021-46150, CVE-2021-46149, CVE-2021-46148, CVE-2021-46147, CVE-2021-46146, CVE-2021-45474, CVE-2021-45473, CVE-2021-45472, CVE-2021-45471).
  2. Fixed an issue where users might fail to install the package.
  3. Fixed an issue where users might encounter the 500 error after updating the package.
  4. Minor bug fixes.

Version: 1.35.5-1050


(2022-04-26)

Compatibility and Installation

  1. Apache 2.4 is required.
  2. Updated to be compatible with DSM 7.0.

Version: 1.35.5-1056


(2022-02-17)

Important Note

  1. Starting from this version, MediaWiki no longer supports retaining or restoring package-related data after an uninstallation.

Compatibility and Installation

  1. PHP 7.4 is required.
  2. Apache 2.4 is required.

What's New

  1. Updated to version 1.35.5.

Fixed Issues

  1. Fixed multiple security vulnerabilities (CVE-2021-41798, CVE-2021-41799, CVE-2021-41800, CVE-2021-45038, CVE-2021-44857, CVE-2021-44858, CVE-2021-46150, CVE-2021-46149, CVE-2021-46148, CVE-2021-46147, CVE-2021-46146, CVE-2021-45474, CVE-2021-45473, CVE-2021-45472, CVE-2021-45471).
  2. Fixed an issue where users might fail to install the package.
  3. Fixed an issue where users might encounter the 500 error after updating the package.
  4. Minor bug fixes.

Version: 1.35.3-0144


(2021-09-07)

What's New

  1. Updated to version 1.35.3.

Fixed Issues

  1. Fixed multiple security vulnerabilities (CVE-2021-35197, CVE-2021-30159, CVE-2021-30155, CVE-2021-30152, CVE-2021-30458, CVE-2021-30156, CVE-2021-30154, CVE-2021-30157, CVE-2021-30158).
  2. Minor bug fixes.

Version: 1.35.3-1040


(2021-08-31)

What's New

  1. Updated to version 1.35.3.

Fixed Issues

  1. Fixed multiple security vulnerabilities (CVE-2021-35197, CVE-2021-30159, CVE-2021-30155, CVE-2021-30152, CVE-2021-30458, CVE-2021-30156, CVE-2021-30158, CVE-2021-30157, CVE-2021-30154).
  2. Minor bug fixes.

Version: 1.35.1-1033


(2021-06-01)

Compatibility and Installation

  1. Updated to be compatible with DSM 7.0.
  2. If PHP 7.3 was not installed, the system will automatically install it after the update to ensure package functionality.

What's New

  1. Updated to MediaWiki 1.35.1.

Version: 1.35.1-0140


(2021-02-23)

Important Note

  1. This update is expected to be available in all regions within the next few days. The actual time of release may vary slightly depending on regions.

What's New

  1. Updated to version 1.35.1.
  2. PHP 7.3 is required.

Fixed Issues

  1. Fixed multiple security vulnerabilities (CVE-2020-35480, CVE-2020-35479, CVE-2020-35477, CVE-2020-35478, CVE-2020-35474, CVE-2020-35475, CVE-2020-25813, CVE-2020-25814, CVE-2020-25815, CVE-2020-25828, CVE-2020-25869, CVE-2020-15005, CVE-2020-10959, CVE-2020-10960, CVE-2019-19709).
  2. Minor bug fixes.

Version: 1.33.1-0136


(2020-04-28)

What's New

  1. Updated to version 1.33.1.
  2. PHP 7.2 is required.

Version: 1.30.0-0131


(2018-03-20)
  1. Upgraded to version 1.30.0 to fix multiple security vulnerabilities regarding MediaWiki (CVE-2017-8814, CVE-2017-8812, CVE-2017-8815, CVE-2017-8810, CVE-2017-8809, CVE-2017-8808, CVE-2017-8811).

Version: 1.28.2-0126


(2017-12-13)
  1. Enhanced overall stability.

Version: 1.28.2-0125


(2017-06-29)
  1. Upgraded to be compatible with MariaDB 10.

Version: 1.28.2-0122


(2017-05-03)

Upgraded to version 1.28.2 to address multiple vulnerabilities (CVE-2017-0361, CVE-2017-0362, CVE-2017-0363, CVE-2017-0364, CVE-2017-0365, CVE-2017-0366, CVE-2017-0367, CVE-2017-0368, CVE-2017-0369, CVE-2017-0370 and CVE-2017-0372).

Version: 1.27.1-0119


(2017-04-25)
  1. Upgrade the compatibility level of MediaWiki 1.27 or later

Version: 1.27.1-0118


(2017-02-21)
  1. Fixed an issue where incompatible databases might be installed during installation.

Version: 1.27.1-0117


(2017-01-04)
  1. Upgraded to 1.27.1.

Version: 1.26.2-0110


(2016-06-22)
  1. Upgraded to version 1.26.2.

Version: 1.23.13-0108


(2016-03-03)
  1. Upgraded version to 1.23.13.

Version: 1.23.10-0029


(2015-09-10)
  1. Upgraded to version 1.23.10.

Version: 1.23.9-0028


(2015-05-12)
  1. Upgraded MediaWiki to 1.23.9 to address multiple vulnerabilities (CVE-2015-2931, CVE-2015-2932, CVE-2015-2933, CVE-2015-2934, CVE-2015-2935, CVE-2015-2936, CVE-2015-2937, CVE-2015-2938, CVE-2015-2939, CVE-2015-2940, CVE-2014-9714, CVE-2015-2941, CVE-2014-9276, CVE-2014-9277, CVE-2014-9476, and CVE-2014-9507).

Version: 1.23.8-0027


(2015-03-12)
  1. Upgraded MediaWiki to 1.23.8.
  2. Fixed multiple vulnerabilities (CVE-2014-9507, CVE-2014-9476, CVE-2014-9276, and CVE-2014-9277).

Version: 1.23.5-0025


(2014-11-07)
  1. Changing the password for MariaDB will now automatically update the password for this package.
  2. Upgraded MediaWiki to 1.23.5 to address two security vulnerabilities (CVE-2014-7199 and CVE-2014-7295)

Version: 1.22.9-0024


(2014-09-23)
  1. Certified by Synology Trust Level.

Improvements

  1. Upgrade MediaWiki to 1.22.9.

Version: 1.22.6-0022


(2014-05-15)

Fixed Issues

  1. Updated to version 1.22.6 to address a XSS vulnerability. Reference: CVE-2014-2853

Version: 1.22.5-0021


(2014-04-29)

Improvements

  1. Upgraded to version 1.22.5.

Version: 1.19.0-0020


(2014-03-10)
  1. Updated to be compatible with DSM 5.0.

Version: 1.19.0-0009


(2013-10-18)
  1. Added new models support

Version: 1.19.0-0008


(2012-10-02)
  1. Fixed an issue where MediaWiki website cannot be set as a virtual host.