Release Notes for Joomla

Joomla is a popular content management system (CMS), which enables you to build powerful Web sites and online applications. With its ease-of-use and extensibility, Joomla can keep track of every piece of content on your Web site. From corporate Web sites to personal homepages, Joomla makes web site building easier and faster.

Version: 3.10.3-1050


(2022-04-26)

Compatibility and Installation

  1. Apache 2.4 is required.
  2. Updated to be compatible with DSM 7.0.

Version: 3.10.3-1055


(2022-02-17)

Important Note

  1. Starting from this version, Joomla no longer supports retaining or restoring package-related data after an uninstallation.

Compatibility and Installation

  1. PHP 7.4 is required.
  2. Apache 2.4 is required.

What's New

  1. Updated to version 3.10.3.

Fixed Issues

  1. Fixed multiple security vulnerabilities (CVE-2021-26039, CVE-2021-26038, CVE-2021-26037, CVE-2021-26036, CVE-2021-26035, CVE-2021-26034, CVE-2021-26033, CVE-2021-26032, CVE-2021-26031, CVE-2021-26030, CVE-2021-26029, CVE-2021-26028, CVE-2021-26027, CVE-2021-26027, CVE-2021-23131, CVE-2021-23130, CVE-2021-23129, CVE-2021-23128, CVE-2021-23127, CVE-2021-23126).
  2. Fixed an issue where "404 not found error" page might occur when Joomla was switched to maintenance mode.
  3. Minor bug fixes.

Version: 3.9.24-1033


(2021-08-31)

Fixed Issue

  1. Minor bug fixes.

Version: 3.9.24-1029


(2021-06-01)

Compatibility and Installation

  1. Updated to be compatible with DSM 7.0.
  2. If PHP 7.3 was not installed, the system will automatically install it after the update to ensure package functionality.

What's New

  1. Updated to Joomla 3.9.24.

Version: 3.9.21-0184


(2022-03-08)

Important Note

  1. Starting from this version, Joomla no longer supports retaining or restoring package-related data after an uninstallation.

Compatibility and Installation

  1. PHP 7.4 is required.
  2. Apache 2.4 is required.

Fixed Issues

  1. Minor bug fixes.

Version: 3.9.21-0177


(2021-09-07)

Fixed Issue

  1. Minor bug fixes.

Version: 3.9.21-0175


(2021-02-23)

Important Note

  1. This update is expected to be available in all regions within the next few days. The actual time of release may vary slightly depending on regions.

What's New

  1. Updated to version 3.9.21 .
  2. PHP 7.3 is required.

Fixed Issues

  1. Fixed multiple security vulnerabilities (CVE-2020-24598, CVE-2020-24599, CVE-2020-15698, CVE-2020-15699, CVE-2020-15700, CVE-2020-15697, CVE-2020-15696, CVE-2020-15695, CVE-2020-13760, CVE-2020-13761, CVE-2020-13762, CVE-2020-13763, CVE-2020-10243, CVE-2020-10242, CVE-2020-10241, CVE-2020-10240, CVE-2020-10239, CVE-2020-10238, CVE-2020-8420, CVE-2020-8421).
  2. Minor bug fixes.

Version: 3.9.14-0170


(2020-04-28)

What's New

  1. Updated to version 3.9.14.
  2. PHP 7.2 is required.

Version: 3.8.8-0166


(2018-08-29)
  1. Fixed multiple security vulnerabilities regarding Joomla (CVE-2018-11325, CVE-2018-11323, CVE-2018-11322).

Version: 3.8.4-0165


(2018-03-20)
  1. Upgraded to version 3.8.4 to fix multiple security vulnerabilities regarding Joomla (CVE-2017-14596, CVE-2017-16634, CVE-2017-16633, CVE-2018-6376, CVE-2018-6377, CVE-2018-6379, CVE-2018-6380).

Version: 3.8.0-0161


(2017-12-13)
  1. Enhanced overall stability.

Version: 3.8.0-0160


(2017-09-27)
  1. Upgraded to version 3.8.0 to fix two security vulnerabilities regarding Joomla (CVE-2017-14595 and CVE-2017-14596).

Version: 3.7.1-0157


(2017-06-29)
  1. Upgraded to be compatible with MariaDB 10.
  2. Fixed an issue where Joomla cannot be started after the package database password is changed via MariaDB.
  3. Upgraded to version 3.7.1 to address a vulnerability (CVE-2017-8917).

Version: 3.6.5-0154


(2017-01-04)
  1. Upgraded to 3.6.5.
  2. Added restore page for users to choose whether to proceed with new installation or to restore if backup data is available.
  3. Added database user page to allow users to assign a database user exclusively for the package.

Version: 3.6.4-0116


(2016-10-27)
  1. Upgraded Joomla to 3.6.4 to address multiple vulnerabilities (CVE-2016-8869 and CVE-2016-8870).

Version: 3.4.7-0109


(2016-03-03)
  1. Updated the backend server to ngnix for enhanced performance.

Version: 3.10.3-1050


(2022-04-26)

Compatibility and Installation

  1. Apache 2.4 is required.
  2. Updated to be compatible with DSM 7.0.

Version: 3.9.21-0184


(2022-03-08)

Important Note

  1. Starting from this version, Joomla no longer supports retaining or restoring package-related data after an uninstallation.

Compatibility and Installation

  1. PHP 7.4 is required.
  2. Apache 2.4 is required.

Fixed Issues

  1. Minor bug fixes.

Version: 3.10.3-1055


(2022-02-17)

Important Note

  1. Starting from this version, Joomla no longer supports retaining or restoring package-related data after an uninstallation.

Compatibility and Installation

  1. PHP 7.4 is required.
  2. Apache 2.4 is required.

What's New

  1. Updated to version 3.10.3.

Fixed Issues

  1. Fixed multiple security vulnerabilities (CVE-2021-26039, CVE-2021-26038, CVE-2021-26037, CVE-2021-26036, CVE-2021-26035, CVE-2021-26034, CVE-2021-26033, CVE-2021-26032, CVE-2021-26031, CVE-2021-26030, CVE-2021-26029, CVE-2021-26028, CVE-2021-26027, CVE-2021-26027, CVE-2021-23131, CVE-2021-23130, CVE-2021-23129, CVE-2021-23128, CVE-2021-23127, CVE-2021-23126).
  2. Fixed an issue where "404 not found error" page might occur when Joomla was switched to maintenance mode.
  3. Minor bug fixes.

Version: 3.9.21-0177


(2021-09-07)

Fixed Issue

  1. Minor bug fixes.

Version: 3.9.24-1033


(2021-08-31)

Fixed Issue

  1. Minor bug fixes.

Version: 3.9.24-1029


(2021-06-01)

Compatibility and Installation

  1. Updated to be compatible with DSM 7.0.
  2. If PHP 7.3 was not installed, the system will automatically install it after the update to ensure package functionality.

What's New

  1. Updated to Joomla 3.9.24.

Version: 3.9.21-0175


(2021-02-23)

Important Note

  1. This update is expected to be available in all regions within the next few days. The actual time of release may vary slightly depending on regions.

What's New

  1. Updated to version 3.9.21 .
  2. PHP 7.3 is required.

Fixed Issues

  1. Fixed multiple security vulnerabilities (CVE-2020-24598, CVE-2020-24599, CVE-2020-15698, CVE-2020-15699, CVE-2020-15700, CVE-2020-15697, CVE-2020-15696, CVE-2020-15695, CVE-2020-13760, CVE-2020-13761, CVE-2020-13762, CVE-2020-13763, CVE-2020-10243, CVE-2020-10242, CVE-2020-10241, CVE-2020-10240, CVE-2020-10239, CVE-2020-10238, CVE-2020-8420, CVE-2020-8421).
  2. Minor bug fixes.

Version: 3.9.14-0170


(2020-04-28)

What's New

  1. Updated to version 3.9.14.
  2. PHP 7.2 is required.

Version: 3.8.8-0166


(2018-08-29)
  1. Fixed multiple security vulnerabilities regarding Joomla (CVE-2018-11325, CVE-2018-11323, CVE-2018-11322).

Version: 3.8.4-0165


(2018-03-20)
  1. Upgraded to version 3.8.4 to fix multiple security vulnerabilities regarding Joomla (CVE-2017-14596, CVE-2017-16634, CVE-2017-16633, CVE-2018-6376, CVE-2018-6377, CVE-2018-6379, CVE-2018-6380).

Version: 3.8.0-0161


(2017-12-13)
  1. Enhanced overall stability.

Version: 3.8.0-0160


(2017-09-27)
  1. Upgraded to version 3.8.0 to fix two security vulnerabilities regarding Joomla (CVE-2017-14595 and CVE-2017-14596).

Version: 3.7.1-0157


(2017-06-29)
  1. Upgraded to be compatible with MariaDB 10.
  2. Fixed an issue where Joomla cannot be started after the package database password is changed via MariaDB.
  3. Upgraded to version 3.7.1 to address a vulnerability (CVE-2017-8917).

Version: 3.6.5-0154


(2017-01-04)
  1. Upgraded to 3.6.5.
  2. Added restore page for users to choose whether to proceed with new installation or to restore if backup data is available.
  3. Added database user page to allow users to assign a database user exclusively for the package.

Version: 3.6.4-0116


(2016-10-27)
  1. Upgraded Joomla to 3.6.4 to address multiple vulnerabilities (CVE-2016-8869 and CVE-2016-8870).

Version: 3.4.7-0109


(2016-03-03)
  1. Updated the backend server to ngnix for enhanced performance.

Version: 3.4.7-0034


(2015-12-31)
  1. Upgraded Joomla to version to 3.4.7 to address two vulnerabilities regarding Session Hardening and SQL injection.

Version: 3.4.5-0033


(2015-10-29)
  1. Upgraded to Joomla 3.4.5 to address multiple security vulnerabilities (CVE-2015-7297, CVE-2015-7857, CVE-2015-7858).

Version: 3.3.6-0032


(2015-05-12)

This is the initial release to add support for DS216play.

  1. Upgraded Joomla to 3.3.6.

Version: 3.3.5-0031


(2014-11-07)
  1. Upgraded to Joomla 3.3.5 to address two security vulnerabilities (CVE-6631 and CVE-7229).

Version: 3.3.3-0029


(2014-09-23)
  1. Certified by Synology Trust Level.

Improvements

  1. Upgraded Joomla to version 3.3.3 for UI redesign.

Version: 2.5.9-0026


(2014-04-29)
  1. Updated to be compatible with DSM 5.0.

Version: 2.5.9-0011


(2013-04-18)
  1. Upgraded Joomla to version 2.5.9.