Synology-SA-21:03 DSM

Publish Time: 2021-02-23 03:15:43 UTC+8

Last Updated: 2021-04-22 04:01:22 UTC+8

Severity
Important
Status
Pending

Abstract

Multiple vulnerabilities allow remote attackers to obtain sensitive information or local users to execute arbitrary code via a susceptible version of DiskStation Manager (DSM).

Affected Products

Product Severity Fixed Release Availability
DSM 6.2 Important Upgrade to 6.2.4-25553 or above.
DSM UC 3.0 Important Pending
SkyNAS Important Pending
VS960HD Important Pending

Mitigation

None

Detail

  • CVE-2021-26563
    • Severity: Important
    • CVSS3 Base Score: 8.2
    • CVSS3 Vector: CVSS:3.1/AV:L/AC:L/PR:H/UI:N/S:C/C:H/I:H/A:H
    • Improper access control vulnerability in synoagentregisterd in Synology DiskStation Manager (DSM) before 6.2.3-25426-3 allows local users to obtain sensitive information via a crafted kernel module.

Acknowledgement

Claudio Bozzato of Cisco Talos

Revision

Revision Date Description
1 2021-02-23 Initial public release.
2 2021-04-22 Disclosed vulnerability details.