Synology-SA-19:36 PHP

Publish Time: 2019-11-01 12:47:01 UTC+8

Last Updated: 2019-11-01 12:47:01 UTC+8

Severity
Important
Status
Ongoing

Abstract

CVE-2019-11043 allows remote attackers to execute arbitrary code via a susceptible version of PHP 7.2, or PHP 7.3.

Affected Products

Product Severity Fixed Release Availability
PHP 7.2 Important Ongoing
PHP 7.3 Important Ongoing

Mitigation

None

Detail

  • CVE-2019-11043
    • Severity: Important
    • CVSS3 Base Score: 8.1
    • CVSS3 Vector: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H
    • In PHP versions 7.1.x below 7.1.33, 7.2.x below 7.2.24 and 7.3.x below 7.3.11 in certain configurations of FPM setup it is possible to cause FPM module to write past allocated buffers into the space reserved for FCGI protocol data, thus opening the possibility of remote code execution.

Reference

Revision

Revision Date Description
1 2019-11-01 Initial public release.